Here is an update to the Capture One + Canon + RecentOSX issues:

It explains the situation as it stands and links to the Phase One forum in which a user explains how to implement a solution.

Until Canon updates their 3rd party SDK for compatibility (which presumably shouldn't be long from now) this is the only way to tether the 5DIII or 1Dx in 10.7.5 or 10.8.

If you have any questions feel free to post them here and I'll do my best to answer.