Site Sponsors
Results 1 to 2 of 2

Thread: Phocus for PC Ver. 1.0 is available

  1. #1
    Senior Member
    Join Date
    Mar 2008
    Post Thanks / Like

    Phocus for PC Ver. 1.0 is available

    I just tried it. It's stable on my computer (Vista OS).
    I haven't seen any of the problems that was known in the last beta version.

    H3DII-31, 5DII, M8, NEX-3 and Camera collection
    Facebook Page

  2. #2
    Member Paul Claesson Hasselblad's Avatar
    Join Date
    Oct 2008
    Union, New Jersey, USA
    Post Thanks / Like

    Re: Phocus for PC Ver. 1.0 is available

    Phocus 1.0 for Windows is available at

    This first version of Phocus for Windows delivers the attractive and well known Phocus user-friendly interface, as well as an excellent performance on the Windows platform.

    System Requirements
    Windows XP SP2 or Vista SP1 running in 32 or 64 bit mode. Intel Core 2 Duo or AMD equivalent processors, with min. 2Gb of RAM and min. 256Mb of graphics card memory. Phocus 1.0 may run on older operating systems and equipment. To ensure a good user experience, we however recommend that your system at least conform to the requirements described above. For a detailed list of system requirements and limitations please consult the Phocus read-me file.

    All Hasselblad firewire based digital camera products are supported in Phocus. 3F files generated by Phocus are not backward compatible with FlexColor. Flextight scanner 3F files are not compatible with Phocus.

    Paul Claesson
    Hasselblad USA

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts