Site Sponsors
Results 1 to 5 of 5

Thread: Problems in updating G1 firmware to v. 1.4?

  1. #1
    Subscriber Member kit laughlin's Avatar
    Join Date
    Nov 2007
    Location
    Two suitcases and the latest MBA
    Posts
    1,334
    Post Thanks / Like

    Exclamation Problems in updating G1 firmware to v. 1.4?

    Update:

    I found that the name of the .bin file had been altered by my computer (had an extra digit appended); I changed it to the correct name, and it has updated fine.


    The moderator may care to delete this post; I could not see how to do that. KL

    I found that following Panasonic's directions (see below) just does not produce the desired results:

    First, the download itself, from this site:

    http://panasonic.jp/support/global/c...fts/dl/g1.html

    but it's not clear from Panny's own site what the v. number for the Sept. 17 update is. Currently, my body firmware is ver. 1.3; I thought that the latest firmware is 1.4, following this notice:

    http://www.dcviews.com/press/panasonic-g1-4.htm

    Back to the the directions:

    http://panasonic.jp/support/global/c...fts/index.html

    I extracted the file and loaded it to a freshly formatted SD card; and put that into the camera (itself loaded with a just-charged battery), turned it on and pressed Play (following p. 2 of the instructions, and no <fig.> 3 (the Update screen) appears.

    Anyone able to shed any light on this?

    Cheers, kl
    Last edited by kit laughlin; 29th September 2009 at 20:03.

  2. #2
    Senior Member Y.B.Hudson III's Avatar
    Join Date
    Jan 2008
    Posts
    314
    Post Thanks / Like

    Re: Problems in updating G1 firmware to v. 1.4?

    format the card, then take two jpg. pics. Now you can proceed...

  3. #3
    Subscriber Member kit laughlin's Avatar
    Join Date
    Nov 2007
    Location
    Two suitcases and the latest MBA
    Posts
    1,334
    Post Thanks / Like

    Re: Problems in updating G1 firmware to v. 1.4?

    It was my mistake, YB: the computer had appended a "-1" to the file's name; accordingly, the G1 did not recognise it as the one it was looking for.

    Change the name; worked perfectly. Thanks

  4. #4
    Senior Member pellicle's Avatar
    Join Date
    May 2009
    Location
    Southport, Australia
    Posts
    1,429
    Post Thanks / Like

    Re: Problems in updating G1 firmware to v. 1.4?

    ahh ... classic download manager thing ... glad its sorted ... ;-)

  5. #5
    Subscriber Member kit laughlin's Avatar
    Join Date
    Nov 2007
    Location
    Two suitcases and the latest MBA
    Posts
    1,334
    Post Thanks / Like

    Re: Problems in updating G1 firmware to v. 1.4?

    Yessss.... I downloaded it a few times, because I did not get the exact byte match, and the download manager (very reasonably!) incremented the file number; that got translated to the expanded file. cheers, kl

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •