Site Sponsors
Results 1 to 12 of 12

Thread: Does your m43 to FD adapter have some play?

  1. #1
    meilicke
    Guest

    Does your m43 to FD adapter have some play?

    Hi all,

    A few days ago I received an RJ adapter, but it has a bit of play when attached to the camera axially, like it is not firmly seated (but it is, it clicks into place). Also the ring that engages the aperture just barely stays in place. It is very easy to knock it off, resulting in a wide open lens.

    For those of you who have this adapter, is this normal?

    Thanks,
    -Scott

  2. #2
    Senior Member pellicle's Avatar
    Join Date
    May 2009
    Location
    Southport, Australia
    Posts
    1,429
    Post Thanks / Like

    Re: Does your m43 to FD adapter have some play?

    Hi

    not on the FD but on the OM from him. But check carefully that the screws in the mount (holding the chromed part to the adaptor) are firm ... my sample wasn't.

    See my blog for details (scroll to postscriptum at the bottom for specifics).

    I'm using the Ciecio7 one at the moment.

  3. #3
    Senior Member
    Join Date
    Jun 2009
    Location
    San Diego, CA
    Posts
    776
    Post Thanks / Like

    Re: Does your m43 to FD adapter have some play?

    My FD adapter from RJ didn't work at all with the older breech lock FD/FL lenses, although it works fine with the bayonet ones. I had issues with the clearances on the lens side, which didn't allow the lens locking ring to fully turn. The camera side fit fine for me. I sent it back. Looks like it was a non-standard version (didn't have the green alignment dot on the outside). I'm hoping to get a replacement that works soon so I can finally start using my FD/FL lenses. Seems like they might be having some quality control issues.

  4. #4
    Senior Member pellicle's Avatar
    Join Date
    May 2009
    Location
    Southport, Australia
    Posts
    1,429
    Post Thanks / Like

    Re: Does your m43 to FD adapter have some play?

    PhotoSmart42's point is interesting

    I have breech lock extension tubes, and they work nicely with the Ciecio7 ...

    its a cheaper adaptor too

  5. #5
    meilicke
    Guest

    Re: Does your m43 to FD adapter have some play?

    Hrm, Photosmart, I'm not sure my FL lenses are fully locking either. I'll have to check when I get home. I also don't have a green dot (?). Maybe I got yours

    Thanks for the Ciecio7 advise Pellicle. As I tried out my FDs, I came to the conclusion that I don't need the rotating aperture ring, so that adapter should be fine. Does it fit snugly to your camera?

    -Scott

  6. #6
    Senior Member m3photo's Avatar
    Join Date
    Dec 2008
    Posts
    1,043
    Post Thanks / Like
    Images
    28

    Re: Does your m43 to FD adapter have some play?

    Mine's a double set from RJ: m4/3rds to 4/3rds and then the Nikon to 4/3rds ring - they've always had some play but I live with it as the images are unaffected.

  7. #7
    Senior Member JBurnett's Avatar
    Join Date
    Aug 2009
    Location
    Bridgewater, Nova Scotia
    Posts
    530
    Post Thanks / Like
    Images
    2

    Re: Does your m43 to FD adapter have some play?

    I have the RJ adapter and nFD lenses. The adapter fits snugly both to the camera body and to the lenses.
    Best regards,
    John.
    http://jburnett.ca

  8. #8
    meilicke
    Guest

    Re: Does your m43 to FD adapter have some play?

    OK, thanks. Does the aperture ring on the adapter stay put? I am still not home to try tightening the screws to see if that helps.

    -Scott

  9. #9
    Senior Member JBurnett's Avatar
    Join Date
    Aug 2009
    Location
    Bridgewater, Nova Scotia
    Posts
    530
    Post Thanks / Like
    Images
    2

    Re: Does your m43 to FD adapter have some play?

    Aperture ring on my adapter stays put, too. Good luck with yours. I've read some posts indicating that RJ is pretty responsive if there's a problem.
    Best regards,
    John.
    http://jburnett.ca

  10. #10
    Senior Member
    Join Date
    Jun 2009
    Location
    San Diego, CA
    Posts
    776
    Post Thanks / Like

    Re: Does your m43 to FD adapter have some play?

    Quote Originally Posted by JBurnett View Post
    Aperture ring on my adapter stays put, too. Good luck with yours. I've read some posts indicating that RJ is pretty responsive if there's a problem.
    He's been pretty responsive. The downside is waiting for the stuff to ship back and forth to China (3-4 weeks each way). So I'm hoping to be able to use my FD lenses after waiting about 3 months from initial order.

    As an aside, I don't have an issue with the aperture ring on the adapter from locking. It works fine. My issue has been with the lens locking ring locking, which prevents me from going to max aperture with my lenses. nFD lenses work fine (I just don't have any since they're more expensive).

  11. #11
    Senior Member pellicle's Avatar
    Join Date
    May 2009
    Location
    Southport, Australia
    Posts
    1,429
    Post Thanks / Like

    Re: Does your m43 to FD adapter have some play?

    Hi

    Quote Originally Posted by meilicke View Post
    Thanks for the Ciecio7 advise Pellicle. As I tried out my FDs, I came to the conclusion that I don't need the rotating aperture ring, so that adapter should be fine. Does it fit snugly to your camera?
    yep ... they're made from a single tooled bit of alloy ... the new ones don't even have a 'pin' anymore its all tooled. I've got a mate in computer lathing and he reckons its top notch work.

    See my blog and here.

  12. #12
    meilicke
    Guest

    Re: Does your m43 to FD adapter have some play?

    Quote Originally Posted by pellicle View Post
    Hi

    yep ... they're made from a single tooled bit of alloy ... the new ones don't even have a 'pin' anymore its all tooled. I've got a mate in computer lathing and he reckons its top notch work.

    See my blog and here.
    your blog was very useful in deciding which adapter to with, so thank you for posting your experiences.

    As far as RJ goes, he has been very prompt and courtious. My guess is that the adapter will go back, but I will wait a bit to see if anything can be done. I do not relish taking the time for all of the shipping.

    Thanks everyone!

    Scott

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •