Site Sponsors
Results 1 to 5 of 5

Thread: Manual Focus of Legacy Lens on G1

  1. #1
    bruce1s
    Guest

    Manual Focus of Legacy Lens on G1

    I received my first legacy lenses in the mail today.

    I found threads on this site instructing me how to get the G1 MF Assist zoom function to work with legacy lenses. I also read discussions of why it couldn't be made automatic.

    Since most of the threads were from 2009 I will ask anew if anyone has discovered a better way. Currently I press the Left arrow button and then press the center button. That works but I don't like it.

    Thank you.

    PS: I don't blame Panasonic. I like the G1 and I am grateful they produced it.

  2. #2
    Senior Member Y.B.Hudson III's Avatar
    Join Date
    Jan 2008
    Posts
    314
    Post Thanks / Like

    Re: Manual Focus of Legacy Lens on G1

    ... roll your thumb across the left arrow on the way to press the center button, in one motion... or buy a G2...

  3. #3
    bruce1s
    Guest

    Re: Manual Focus of Legacy Lens on G1

    Thanks for responding. I'm disappointed to hear there is no solution for the G1. I like the G1 enough to keep it a while longer. I also find it encouraging to hear they fixed the problem in the next generation.

  4. #4
    Senior Member
    Join Date
    Jun 2009
    Location
    San Diego, CA
    Posts
    776
    Post Thanks / Like

    Re: Manual Focus of Legacy Lens on G1

    It's not an issue once you get used to it. It becomes second nature and you don't even think about it. Not a big deal really.
    -Dragos
    Panasonic GH1/G1, Canon FTb(n)/F-1, Mamiya C330F/RB67 Pro SD, Chamonix 45N-2, Nikon F5 + Assorted Lenses

  5. #5
    Senior Member pellicle's Avatar
    Join Date
    May 2009
    Location
    Southport, Australia
    Posts
    1,429
    Post Thanks / Like

    Re: Manual Focus of Legacy Lens on G1

    mostly I don't even check it ... compared to focusing on the back screen of a GF (where you would really need it) the EVF allows me to get the focus pretty perfect on its own. Mostly when I do check it it was fine anyway

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •