Site Sponsors
Results 1 to 3 of 3

Thread: EP-3 bricked recovery options?

  1. #1
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    EP-3 bricked recovery options?

    Put in the latest firmware on my Olympus EP-3 today but camera won't turn on now. Is there any recovery procedure or do I have to send the camera in for service?

  2. #2
    Senior Member Annna T's Avatar
    Join Date
    Jul 2009
    Location
    Swiss Alps
    Posts
    1,444
    Post Thanks / Like
    Images
    3

    Re: EP-3 bricked recovery options?

    Quote Originally Posted by TimWright View Post
    Put in the latest firmware on my Olympus EP-3 today but camera won't turn on now. Is there any recovery procedure or do I have to send the camera in for service?
    I'd try to upload the firmware a second time. Just in case it works. I find the Olympus updates rather tricky. Instead of downloading the firmware update and copying it to the SD card, you have to hook the camera directly, which is tedious because it takes a long time and the lcd remains blacked out without telling anything for way too long.

    Then, when the warning telling that you should wait for the OK sign without touching any button. it doesn't even last as long as the blacked out lcd before. I find this behaviour weird and a possible source of confusion for people lacking the patience. I've been tempted to stop the process many times, but happily didn't and never got a problem.

    Anyway, before sending the camera back, which is a hassle, I'd try to redo the operation another time, but wait a long time before doing anything with the buttons and use a full loaded battery.

    Good luck

  3. #3
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: EP-3 bricked recovery options?

    Thanks for the info but I am sure it is dead. Left it with the battery out over night then put in a fresh battery but it won't even turn on. Dropping it at the dealer who will send it in for me. I have done many updates to various cameras but this is the first time an update has "bricked" a camera on me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •