Site Sponsors
Results 1 to 10 of 10

Thread: 5DMKII Dead?

  1. #1
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Ithaca, NY
    Posts
    3,540
    Post Thanks / Like

    5DMKII Dead?

    I took the camera out today, set up on tripod with my new 24 TS-E II, did prelim framing in viewfinder, clicked on live view and no image - just black screen. Tried taking images (with and w/o live view) and all appear black. Opened one in CS5/ACR and did auto levels and result is below. We have had extremely humid weather for the past few days but the camera worked perfectly until today. Still under warranty and I've reported problem to Canon, but has anyone else run into a similar problem with the 5DII?

    Carl
    Gallery

  2. #2
    Administrator Bob's Avatar
    Join Date
    Oct 2007
    Location
    Prescott, Arizona
    Posts
    4,492
    Post Thanks / Like
    Images
    367

    Re: 5DMKII Dead?

    Nope, I have not seen that with the 5DII,
    Although I am pretty sure that there won't be any difference, have you tried with another card?
    If that is the same, as I think it will be, it is time for emergency treatment for the poor thing.
    -bob

  3. #3
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Ithaca, NY
    Posts
    3,540
    Post Thanks / Like

    Re: 5DMKII Dead?

    Quote Originally Posted by Bob View Post
    Nope, I have not seen that with the 5DII,
    Although I am pretty sure that there won't be any difference, have you tried with another card?
    If that is the same, as I think it will be, it is time for emergency treatment for the poor thing.
    -bob
    Thanks Bob. Yes, I tried a different card with same results. Afraid you are right and will need to send the camera to Canon service.
    Carl
    Gallery

  4. #4
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: 5DMKII Dead?

    Ouch, bummer...
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  5. #5
    tokengirl
    Guest

    Re: 5DMKII Dead?

    Quote Originally Posted by scho View Post

    My, what a pretty tartan.

    Sorry to hear you've got troubles right as you're about to start using your new TS-E. That's a MAJOR bummer right there.

  6. #6
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Ithaca, NY
    Posts
    3,540
    Post Thanks / Like

    Re: 5DMKII Dead?

    Jack and TokenGirl,

    Thanks for your sympathy - bummer is right. First email response just now from Canon tech support was to see if mirror and shutter are working properly - they are working fine. Next step will be a call Monday AM to the service center and shipping it off for repair. Strange, because although the humidity was up, it was not extreme and the camera wasn't exposed to any abrupt changes in either temperature or humidity. I've been using my little G1-IR camera along with the 5DII and the G1 is doing just fine (also works well with the 24 TS-E II).
    Carl
    Gallery

  7. #7
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Ithaca, NY
    Posts
    3,540
    Post Thanks / Like

    Re: 5DMKII Dead?

    I confirmed with Canon support that the mirror and shutter were fine and they think (as I do) that the sensor is at fault and suggested sending it in for repair. I'm bummed about the camera failure but impressed with the fast response of Canon support (all on a Sunday afternoon in a matter of a few hours). Hopefully repair will also be quick and painless (warranty covered).

    Last support response:

    "Thank you for your inquiry. We value you as a Canon customer and
    appreciate the opportunity to assist you.

    That unfortunately sounds like an issue that would need to be looked at
    by our factory service center. It sounds like their is a problem with
    the image sensor. You may want to try resetting the camera settings and
    custom function in the menu to see is there is a setting causing
    problems but service is likely needed from the description of what is
    happening."
    Carl
    Gallery

  8. #8
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Ithaca, NY
    Posts
    3,540
    Post Thanks / Like

    Re: 5DMKII Dead?

    Just a follow-up on my 5DII failure. Camera came back today from Canon Repair Center in NJ (Quick service turn around). No prior notification or tracking info. Fedex tried to deliver this AM when I was out so I had to go pick up the camera at the Fedex center this evening. Came with simple brown paper wrapping with camera in a ziplock bag all in a brown box. Some quick test shots indicate that camera is OK again. Note said "...it was found that the part was broken so that the power supply did not operate properly. The cmos sensor assembly w/o FB data was replaced and product functions were confirmed. Adjusted exposure & focus, cleaned cmos and checked all to factory specs." I'm not exactly sure what all of that means, but at least I'm back in business again with the 5DII. No charges - all under warranty which expires next month. Whew!!
    Carl
    Gallery

  9. #9
    Senior Member David Schneider's Avatar
    Join Date
    Aug 2010
    Location
    New Jersey, USA
    Posts
    509
    Post Thanks / Like

    Re: 5DMKII Dead?

    Carl,

    When your warranty runs out, consider Toshio at T.F. Camera Repair, 27 Brunswick Woods Drive, East Brunswick, NJ 08816 tel: 732-238-8806. He's in my town and we are just 10 mins from Canon in Jamesburg, NJ. Canon has outsource tens of thousands of repairs to him over the years and he's recognized as one of the leading Canon camera repair techs in the country. He's generally faster, less expensive than Canon, plus you can talk to him. He's very old school and has been doing Canon repairs for 30 years. He's also a friend of mine.

  10. #10
    Member
    Join Date
    Dec 2007
    Location
    Tiburon, CA
    Posts
    108
    Post Thanks / Like

    Re: 5DMKII Dead?

    Glad to hear your 5D2 is working again. I wouldn't want to go through the same thing with mine.

    But I wouldn't toss out that tartan pattern from the faulty sensor. The more I look at it, the better it looks. You might be able to sell it to a fabric designer.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •