Site Sponsors
Results 1 to 21 of 21

Thread: LR 5.4 with X-T1 support has been released!

  1. #1
    Senior Member bradhusick's Avatar
    Join Date
    Nov 2007
    Location
    Seattle, WA USA
    Posts
    2,498
    Post Thanks / Like
    Images
    53

    LR 5.4 with X-T1 support has been released!

    not a beta, the real thing!
    Brad Husick

  2. #2
    Super Duper
    Senior Member
    etrigan63's Avatar
    Join Date
    Nov 2007
    Location
    Earth, Sol System (near Miami, FL)
    Posts
    2,501
    Post Thanks / Like
    Images
    21

    Re: LR 5.4 with X-T1 support has been released!

    Adobe CC subscribers will get the update via the CC control panel. Lightroom updates within itself. Don't forget to download the DNG Converter as well.
    Carlos Echenique | Carlos Echenique Photography |Olympus OM-D E-M1 MK II | Olympus Pen-F - M.Zuiko 17mm f/1.8, M.Zuiko 25mm f/1.8, M.Zuiko 45mm f/1.8, Rokinon 12mm f/2 NCS, M.Zuiko 75mm f/1.8, M.Zuiko 12-40mm f/2.8 PRO, M.Zuiko 40-150mm f/2.8 PRO

  3. #3
    Senior Member bradhusick's Avatar
    Join Date
    Nov 2007
    Location
    Seattle, WA USA
    Posts
    2,498
    Post Thanks / Like
    Images
    53

    Re: LR 5.4 with X-T1 support has been released!

    gotta love this...
    Last edited by bradhusick; 17th July 2014 at 09:06.
    Brad Husick

  4. #4
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    No kidding....

    Whole new ballgame...Jono take a look!


    Fuji X-T1 LR 5.4 Astia Profile













    Well worth the wait....


    Thanks,

    Bob
    Likes 1 Member(s) liked this post

  5. #5
    Senior Member
    Join Date
    Dec 2008
    Posts
    477
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Performance is quite poor. I'm not talking about image quality, just the performance. Selecting a photo to begin editing it leads to a VERY perceptible delay (up to a count of ten) before LR updates the image to reflect its adjustments. This is radically slower than any other model of camera I have used, and it is so slow that I almost give up at times.

    This is on a fully modern MacBook Pro with an SSD, not an underpowered machine.

    Not sure what is going on, but it is disappointing to say the least...

    Doug

  6. #6
    Workshop Member ptomsu's Avatar
    Join Date
    Nov 2007
    Location
    Austria, close to Vienna
    Posts
    3,871
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by bradhusick View Post
    gotta love this...
    This is the main reason why I might keep Fuji!

    Lovely feature - film simulation from RAW!!!

  7. #7
    Member
    Join Date
    Mar 2011
    Location
    Seattle, WA
    Posts
    64
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by greypilgrim View Post
    Performance is quite poor. I'm not talking about image quality, just the performance. Selecting a photo to begin editing it leads to a VERY perceptible delay (up to a count of ten) before LR updates the image to reflect its adjustments. This is radically slower than any other model of camera I have used, and it is so slow that I almost give up at times.

    This is on a fully modern MacBook Pro with an SSD, not an underpowered machine.

    Not sure what is going on, but it is disappointing to say the least...

    Doug
    Hmm, might be a Mac thing. I have no complaints on Windows.
    Martin Ranger - Seattle, WA
    www.martinrangerimages.com

  8. #8
    Senior Member Mike Woods's Avatar
    Join Date
    Dec 2007
    Location
    Bristol, UK
    Posts
    1,473
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    No issues on my iMac- very quick.

    Mike

  9. #9
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    You might try a re-install....

    I just did a test on a fairly maxed out mid-2010 MAC Pro with the following picture...applied the Astia profile exported to PS CC and nothing in the process was slow...most less than a second to accomplish.




    Fuji X-T1 LR 5.4 Test





    Thanks,


    Bob

  10. #10
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Another from yesterday with a bit more detailed subject but no noticeable lag in process time....



    Fuji X-T1 LR 5.4






    Thanks,


    Bob

  11. #11
    Senior Member bradhusick's Avatar
    Join Date
    Nov 2007
    Location
    Seattle, WA USA
    Posts
    2,498
    Post Thanks / Like
    Images
    53

    Re: LR 5.4 with X-T1 support has been released!

    No performance drop I can tell. (Mac Pro).
    Brad Husick

  12. #12
    Senior Member
    Join Date
    Dec 2008
    Posts
    477
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Interesting, each of you that have macs and are not seeing perf issues are running machines with dedicated video cards as opposed to the video that is part of the Intel chips on the Retina MacBook Pros. I have an iMac (also pretty maxxed out) although it is a bit older. I will try it with LR 5.4 to see if I see a slowdown. If I do not, then I'll have something concrete to send to Adobe.

    Doug

  13. #13
    Senior Member
    Join Date
    Dec 2008
    Posts
    477
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Here is a screen capture movie of the delay I am referring to. Sorry for the crudity of the web page as I am not experienced with posting movies this way.

    The time from selecting the new image to when it darkens will give you an idea of how long this delay is. In the meantime, I am doing nothing but waiting. No user input on the machine at all.

    http://www.castleintheair.com/Movies...lay/index.html

    Doug

  14. #14
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Doug,

    That seems long ... wonder if you can use Activity Monitor to see what is
    causing the delay...if CPU or memory maxes out....

    Love to know how this plays out.

    Thanks,

    Bob

  15. #15
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by bradhusick View Post
    gotta love this...
    How do you access this sub-menu?

    When I click on Profile under Camera Calibration what you show isn't there. What camera file was being used? A Sony A7R file doesn't show those film choices.

    Thanks,

    -Marc

  16. #16
    Super Duper
    Senior Member
    ashwinrao1's Avatar
    Join Date
    Feb 2010
    Location
    Seattle, WA - USA
    Posts
    3,276
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Oh yes. I was lucky to be testing this out over the past 3 weeks. The fuji x trans files do seem substantially better, and to have camera profiles easily at hand in LR seals the deal. Less artifacts too, and images seem sharper and also more a enable to sharpening in LR.
    Ashwin Rao
    Seattle, WA
    My Photography
    Likes 1 Member(s) liked this post

  17. #17
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by fotografz View Post
    How do you access this sub-menu?

    When I click on Profile under Camera Calibration what you show isn't there. What camera file was being used? A Sony A7R file doesn't show those film choices.

    Thanks,

    -Marc
    Its camera specific and only shows for the Fuji....

    So Fuji XE-1(2), X-Pro 1 or X-T1 will give you the option based on
    the X Trans profiles Fuji and Adobe have cooked into the system.


    Bob

  18. #18
    Senior Member fordfanjpn's Avatar
    Join Date
    Nov 2007
    Location
    Tokyo
    Posts
    551
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by greypilgrim View Post
    Performance is quite poor. I'm not talking about image quality, just the performance. Selecting a photo to begin editing it leads to a VERY perceptible delay (up to a count of ten) before LR updates the image to reflect its adjustments. This is radically slower than any other model of camera I have used, and it is so slow that I almost give up at times.

    This is on a fully modern MacBook Pro with an SSD, not an underpowered machine.

    Not sure what is going on, but it is disappointing to say the least...

    Doug
    I'm having the same problem on my new iMac. Importing files seems to take much longer than before. Otherwise it seems to be ok.

    Bill

  19. #19
    Subscriber and Workshop Member
    Join Date
    Dec 2007
    Posts
    2,800
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Another from the LR 5.4 testing....


    Fuji X-T1 ... ignore the EXIF






    Thanks,


    Bob
    Likes 1 Member(s) liked this post

  20. #20
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by docmoore View Post
    Its camera specific and only shows for the Fuji....

    So Fuji XE-1(2), X-Pro 1 or X-T1 will give you the option based on
    the X Trans profiles Fuji and Adobe have cooked into the system.


    Bob
    Thanks Bob! That's what I thought, but wanted to make sure I wasn't missing out on something pretty cool.

    - Marc

  21. #21
    Workshop Member ptomsu's Avatar
    Join Date
    Nov 2007
    Location
    Austria, close to Vienna
    Posts
    3,871
    Post Thanks / Like

    Re: LR 5.4 with X-T1 support has been released!

    Quote Originally Posted by docmoore View Post
    Another from the LR 5.4 testing....


    Fuji X-T1 ... ignore the EXIF






    Thanks,


    Bob
    The results are pretty impressive. Getting RAW resolution and power and being able to apply Fuji Film Simulation is just wonderful!
    Life is an ever changing journey
    http://photography.tomsu.eu/
    https://www.flickr.com/photos/peter_...tography/sets/
    Likes 1 Member(s) liked this post

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •