Either versions ok. (zf1,zf2)

Thanks