The GetDPI Photography Forum

Great to see you here. Join our insightful photographic forum today and start tapping into a huge wealth of photographic knowledge. Completing our simple registration process will allow you to gain access to exclusive content, add your own topics and posts, share your work and connect with other members through your own private inbox! And don’t forget to say hi!

GFX50r: shutter release button issues


Well-known member
Hi there,
my GFX50r shows a weird behaviour: it focuses regularly and indicates that the focus has been found, but there is a considerable delay when I then press the shutter button to actually take the image. It can be more than a few seconds. Would you have any idea what the problem could be? I tried with my GF50mm lens, but also an adapted EF lens via the Fringer adapter.

In low light the issue is worse. I tried a reset of the entire camera without any success. In MF mode there is no delay.

Edit: Now I found out by accident what seems to be the issue: Even though the shutter is completely depressed, no image is taken. If I however press harder, it takes the image. Is that a hardware defect?

Thank you!
Last edited:


Well-known member
Weird. What could be different in regard to the shutter button when shooting MF or AF mode ?


Well-known member
It seems like the following three steps are needed to take a picture:
(1) I first press the shutter half to ensure focus.
(2) Then further press the shutter button - there is a little resistance.
(3) Then I press the shutter button a little further, the picture is taken.

Is that a normal behaviour?
Edit: Pressig the shutter shouldn‘t be a science - I guess there is a hardware malfunction. Will check it out with my dealer.
Last edited: