The GetDPI Photography Forum

Great to see you here. Join our insightful photographic forum today and start tapping into a huge wealth of photographic knowledge. Completing our simple registration process will allow you to gain access to exclusive content, add your own topics and posts, share your work and connect with other members through your own private inbox! And don’t forget to say hi!

What is the max speed of leaf Aptus with Hasselblad lenses?

espelancer

New member
I just got a Leaf Aptus II and Hasselblad 50mm CFi. When I tested the combination with a sync cable connecting the lens and the digital back, I noticed that the shutter speed can only goes to 1/30. If I use 1/60, the digital back will get a black image. I wonder is this expected?
 

FloatingLens

Well-known member
Could have to do with the latency setting for the sync, if there's such an option? At least for P1 backs, there is a long and short latency mode. I don't know the Aptus backs, so it is speculation.
 

Alkibiades

Active member
Leaf Aprtus II backs have usually no problems with faster speeds as older hasselblad backs have. Indeed thay work very well with mechanic shutters like Copal, compur and prontor.
check your adjustments.
 

buildbot

Active member
Could have to do with the latency setting for the sync, if there's such an option? At least for P1 backs, there is a long and short latency mode. I don't know the Aptus backs, so it is speculation.
according to this old photo.net thread, they are always on :https://www.photo.net/discuss/threads/mamiya-pro-s-adapter-hx702.466407/

Makes sense as they have active cooling via fans, I think most sinar backs are similar and are always on too.

Maybe the sync cable is faulty or the contacts in the shutter are dirty causing it sync/fire too slowly?
 
Top