Site Sponsors
Results 1 to 4 of 4

Thread: M 9 cracked sensor

  1. #1
    Senior Member
    Join Date
    Dec 2007
    Posts
    764
    Post Thanks / Like

    M 9 cracked sensor

    Sent my m9 in to Leica for some card isssues it kept saying my cards were locked . It was one of the first 20. they told me i had a cracked sensor and replaced it.

  2. #2
    Senior Member
    Join Date
    Feb 2011
    Posts
    449
    Post Thanks / Like

    Re: M 9 cracked sensor

    Hard luck, but didn't you see the crack? In nearly all cases its a line across one of the corners of the image. Maybe it happened in transit when you sent it in for the card problem?

    Originally it was reported that only a very few (40 or so) cameras where affected from a batch released about Oct/Dec '09 (mine was one), but yours is the earliest I have heard of, and others have appeared outside that timescale.

    Steve

  3. #3
    Senior Member thrice's Avatar
    Join Date
    Aug 2009
    Posts
    1,265
    Post Thanks / Like

    Re: M 9 cracked sensor

    Mine was in that time scale, sensor is still fine I'm confident if it ever cracks Leica will fix it free.

  4. #4
    Workshop Member glenerrolrd's Avatar
    Join Date
    Nov 2007
    Location
    Jupiter FL/Atlanta GA
    Posts
    2,279
    Post Thanks / Like

    Re: M 9 cracked sensor

    I had one of the first batch that broke .....fortunately they fixed it quickly and the M9 has function without a fault since.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •