Site Sponsors
Results 1 to 12 of 12

Thread: New firmware problem

  1. #1
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    New firmware problem

    Just a warning. Installed the new firmware on my M8 and it trashed it. Followed all the procedures as usual and camera will not startup now. And yes I followed all the procedures as I have done with all previous updates. I have had very few problems with this camera so feel it was just bad luck but Leica needs to address these rudimentary problems in a professional level camera. A basic reset firmware built into the rom would allow recovery instead of a trip in for service.

  2. #2
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: New firmware problem

    Quote Originally Posted by TimWright View Post
    Just a warning. Installed the new firmware on my M8 and it trashed it. Followed all the procedures as usual and camera will not startup now. And yes I followed all the procedures as I have done with all previous updates. I have had very few problems with this camera so feel it was just bad luck but Leica needs to address these rudimentary problems in a professional level camera. A basic reset firmware built into the rom would allow recovery instead of a trip in for service.
    Yikes!

  3. #3
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: New firmware problem

    Anyone here no if they can fix this in Allandale or does it have to go to germany? Also any idea on turn around?

  4. #4
    Super Moderator Cindy Flood's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    3,581
    Post Thanks / Like
    Images
    118

    Re: New firmware problem

    Tim,
    Sorry to hear about this. I would call Leica in NJ first thing in the morning and get info directly from them.
    Good luck.

  5. #5
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: New firmware problem

    Thanks, my dealer actually has a shipment going out tomorrow and is going to call his contacts first thing in the morning. He said he will hold the shipment till i get there. He is also headed to Germany, I said maybe he could hand it to them directly.

  6. #6
    Senior Member ecliffordsmith's Avatar
    Join Date
    Mar 2008
    Location
    Antwerpen
    Posts
    467
    Post Thanks / Like

    Re: New firmware problem

    Tim,

    Wow, I am sorry to hear this. I hope it gets resolved quickly.

  7. #7
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: New firmware problem

    Quote Originally Posted by TimWright View Post
    Just a warning. Installed the new firmware on my M8 and it trashed it. Followed all the procedures as usual and camera will not startup now. And yes I followed all the procedures as I have done with all previous updates. I have had very few problems with this camera so feel it was just bad luck but Leica needs to address these rudimentary problems in a professional level camera. A basic reset firmware built into the rom would allow recovery instead of a trip in for service.
    Tim, don't want to appear remeadial, but did you try charging a different battery overnight, and using a different SD card (non-SDHC)?

    My M8 updated fine.

  8. #8
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: New firmware problem

    Yup I left the battery out and tried with a fresh battery and card this morning with no results so off to service it goes.

  9. #9
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: New firmware problem

    Tim, do you by any chance have an early serial number body? I wonder if they got in an early batch of SD readers that weren't spec'd for SDHC?
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  10. #10
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: New firmware problem

    It is early I got mine the first week they were released but I was using a standard card. I spoke to NJ this morning and they said it might be a circuit board failure although I have had no problems other than this. Anyway it is on it's way to NJ.

  11. #11
    Super Moderator Cindy Flood's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    3,581
    Post Thanks / Like
    Images
    118

    Re: New firmware problem

    Tim,
    Did yours ever go back to Solms for the original update?

    My first week M8 went back to Solms early on for the update. It then was one of the first to die of SDS. It was replaced so that Leica could have it back for testing. I was just shooting away when mine died and it had given no indication that it was about to do so.

    It does seem funny that yours would pick that time to go, but better now than after the warranty was up.

  12. #12
    Member
    Join Date
    Nov 2007
    Posts
    202
    Post Thanks / Like

    Re: New firmware problem

    Yes it went back early in the program, I had no problem with it but sent it in anyway. My dealer had arranged to send back a few that he had sold and they went in right at the start of the program. The only problem I have had was a couple of lockups but they were in the winter in freezing temperatures and i am sure it just the battery.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •