Site Sponsors
Results 1 to 13 of 13

Thread: My M8s are overexposing ... is it the new firmware?

  1. #1
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    My M8s are overexposing ... is it the new firmware?

    Both my M8s are back from Leica (3 lenses are still missing in action since Dec.3rd).

    Both the cameras are now overexposing by about 2/3rds of a stop from prior to sending them in.

    Anyone else experiencing this?

  2. #2
    Senior Member simonclivehughes's Avatar
    Join Date
    Jan 2008
    Location
    North Vancouver, BC
    Posts
    1,168
    Post Thanks / Like

    Re: My M8s are overexposing ... is it the new firmware?

    Marc,

    I've updated whenever firmware changed but I've not seen this in either M8 body. I virtually always have them set for -2/3 EV.

    Cheers,

  3. #3
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: My M8s are overexposing ... is it the new firmware?

    Hi Marc:

    The early firmwares caused serious over-exposure in my cameras too, but I have NOT noticed it at all with the last two revisions. In fact, with the last revision, I find AE to be excellent in most situations, which given the M8 exposure technology is a pretty impressive feat IMO...
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  4. #4
    Subscriber robsteve's Avatar
    Join Date
    Nov 2007
    Posts
    1,202
    Post Thanks / Like
    Images
    496

    Re: My M8s are overexposing ... is it the new firmware?

    Quote Originally Posted by fotografz View Post
    Both my M8s are back from Leica (3 lenses are still missing in action since Dec.3rd).

    Both the cameras are now overexposing by about 2/3rds of a stop from prior to sending them in.

    Anyone else experiencing this?
    Did you get a more sensitive sensor or is the metering out?


    Robert

  5. #5
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: My M8s are overexposing ... is it the new firmware?

    One camera was sent in to just align the rangefinder. The other one was an earlier M8 and was sent to Germany for the original fix and to calibrate the rangefinder.

    The only common thing that differentiates them from before sending them in is the newer firmware V 1.201. It seems highly unlikely that both cameras' metering is out of whack exactly the same amount. I'd say in general its closer to 1/3 stop than 2/3s ... in between. At night, or in lower light it seems fine or just slightly off.

    It may just be me, since Leica has had my cameras for 2 lifetimes I may just have a faulty memory : -) The main thing is that the darn things now focus accurately from 24 ASPH to my old 90/2.8 in both portrait and landscape orientation, and the lenses I do have are now calibrated. I can deal with metering.

  6. #6
    Super Duper
    Senior Member
    jonoslack's Avatar
    Join Date
    Nov 2007
    Location
    East Anglia & Cornwall (UK)
    Posts
    11,778
    Post Thanks / Like
    Images
    1

    Re: My M8s are overexposing ... is it the new firmware?

    Quote Originally Posted by fotografz View Post
    One camera was sent in to just align the rangefinder. The other one was an earlier M8 and was sent to Germany for the original fix and to calibrate the rangefinder.

    The only common thing that differentiates them from before sending them in is the newer firmware V 1.201. It seems highly unlikely that both cameras' metering is out of whack exactly the same amount. I'd say in general its closer to 1/3 stop than 2/3s ... in between. At night, or in lower light it seems fine or just slightly off.

    It may just be me, since Leica has had my cameras for 2 lifetimes I may just have a faulty memory : -) The main thing is that the darn things now focus accurately from 24 ASPH to my old 90/2.8 in both portrait and landscape orientation, and the lenses I do have are now calibrated. I can deal with metering.
    Hi Marc
    Sounds like you got a better result than one might have expected - let's hope it's a sign of things to come.
    As far as the metering is concerned, I've not noticed a change - but I've always had mine set to -1/3 or -2/3; maybe it's just unfamiliarity because they took so long!

    Just this guy you know

  7. #7
    Member Hank Graber's Avatar
    Join Date
    Nov 2007
    Posts
    178
    Post Thanks / Like

    Re: My M8s are overexposing ... is it the new firmware?

    My normal setting for the M8 has always been -2/3 EV. I find Leica's ISO ratings very conservative compared to Canon's. In addition I prefer to leave a little more headroom in the highlights with Leica files underexposing a bit more, where with the Canon I'd expose to the right.

  8. #8
    Digital Dude
    Guest

    Re: My M8s are overexposing ... is it the new firmware?

    From a newbie perspective, I prefer having my profiles set at either -1/3 or -2/3rds. Otherwise, it just appears to be a tad light during the daylight for my taste.
    Regards,

  9. #9
    Workshop Member
    Join Date
    Nov 2007
    Posts
    420
    Post Thanks / Like

    Re: My M8s are overexposing ... is it the new firmware?

    I recently sent my M8 into Leica NJ for a rangefinder adjustment and fix on the meter. I had to always dial in a -2/3 EV on the M8 in order to get it to meter the same as my M7 or the Nikon D3.

    It came back within 1 1/2 weeks (in time for my trip to Jamaica that I just got back from) working perfectly in respect to both the focus and metering.

    If you meter requires that you set it to a -2/3 EV then it needs to be adjusted. Send it back to Leica.

    Best,

    Ray

  10. #10
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: My M8s are overexposing ... is it the new firmware?

    Thanks Ray, but I'm NOT deliberately sending anything into the black hole of Leica unless the camera flat out doesn't work, or can't be focused : -)

    I'm just got them back, and weird as it may seem, the meters both worked better before sending them in. But it just may be my faulty memory since they were gone for so long. It seems to be fine in low light, but overexposes in daylight. Gotta pull out the hand meter and test them against it.

  11. #11
    Senior Member
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    2,338
    Post Thanks / Like
    Images
    52

    Re: My M8s are overexposing ... is it the new firmware?

    Marc - it isnt your imagination...

  12. #12
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: My M8s are overexposing ... is it the new firmware?

    Marc: Reinstall the firmware...
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  13. #13
    Administrator, Instructor Guy Mancuso's Avatar
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    23,623
    Post Thanks / Like
    Images
    2555

    Re: My M8s are overexposing ... is it the new firmware?

    Thinking the same thing
    Photography is all about experimentation and without it you will never learn art.

    www.guymancusophotography.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •