Site Sponsors
Results 1 to 28 of 28

Thread: Big Problem with new P65+

  1. #1
    Senior Member
    Join Date
    Jun 2010
    Posts
    270
    Post Thanks / Like

    Big Problem with new P65+

    Halo,

    I bought P65 recently and today I had my 3rd photoshoot.

    The back starts giving me problems after 4-5 hours of usage. At a time when I plug the firewire cable, the back keeps turning on and off repeatedly. You can see the 1 logo then it suddenly black screen and the logo again, almost like trying to start but it cant. I tried unplugging the battery etc and when I almost give up, it works again after I plug in the cable (followed by the camera shutter/mirror, something inside closed.

    Another 4 hours, it gave me a different problem. The battery suddenly went dead, I thought I was running out, took a new one and put it in. The back wont start at all, I tried 3 different batteries.The weird thing was when I put the firewire cable it works (only with cable no battery). I tried to unplug, open the back, reset the setting, and I still cant use the battery to power the back.

    Can someone help me with this?

    For a $45,000 piece of equipment, it sure gave me a shock. It seems the build quality is bad. My $3000 DSLR wont give me this problem after 2-3 years.

    Thanks,
    Dan

  2. #2
    Senior Member stephengilbert's Avatar
    Join Date
    Nov 2007
    Location
    Santa Monica, CA
    Posts
    2,276
    Post Thanks / Like
    Images
    2

    Re: Big Problem with new P65+

    It might be a bit premature to conclude that the build quality is bad based on a problem with a single unit. I believe there are one or two P65s that work okay.

    Call your dealer.

  3. #3
    Workshop Member
    Join Date
    May 2008
    Location
    NYC
    Posts
    3,275
    Post Thanks / Like
    Images
    7

    Re: Big Problem with new P65+

    Contact your dealer. They can help you make sure the problem is not, for instance, due to a defective firewire cable or battery. Very often even symptoms that seem very strongly to indicate a problem with the back are caused by such accessories.

    If it is a problem with the back they will assist you in getting the unit replaced (any issues within the first 30 days are resolved by priority shipping of a new back rather than a repair).

    The build quality of the P+ digital backs is the highest of any camera system I've used. Solid metal construction - no moving parts (other than the CF card door and ejector), and capable of operating without in a very wide range of hot/cold/humidity. See the Extreme Video series - while humorous and marketing oriented they do correctly - in my experience - represent the construction quality and durable/reliable nature of these backs.

    All the money in the world can't guarantee you zero defects. They only guarantee you less of them and great service when they do occur.

    Doug Peterson (e-mail Me)
    __________________
    Head of Technical Services, Capture Integration
    Phase One, Leaf, Cambo, Canon, Apple, Profoto, Eizo & More
    National: 877.217.9870 *| *Cell: 740.707.2183
    Newsletter: Read Latest or Sign Up
    RSS Feed: Subscribe
    Buy Capture One at 10% off
    Personal Work

  4. #4
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Did you contact your dealer before or after your post? If you posted prior to contacting your dealer then I think your assumptions are a tad harsh. If you contacted your dealer then posted then I'd be interested in hearing what the dealer said.

    Was this a result of a private sale?

    Best of luck in figuring out the problem.
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  5. #5
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: Big Problem with new P65+

    In addition to the firewire cable you're using, specific card being used, back firmware and body firmware can all play significant roles...

    All that said, I'd also be very interested in what your dealer says. Good news is that even if you didn't purchase the 3yr VA warranty, you still have a full year of rock solid support from Phase One!
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  6. #6
    Administrator Bob's Avatar
    Join Date
    Oct 2007
    Location
    Prescott, Arizona
    Posts
    4,492
    Post Thanks / Like
    Images
    367

    Re: Big Problem with new P65+

    My experience is that it is a complicated but well supported system.
    The nature of electronic failures, if it is one, is that the frequency of failure is highest in the early hours of use and goes down over time. This is often called the "bathtub curve". The more complicated the system is, and the number of interconnections it has, the more likely a failure might occur especially when it is young.
    Personally I have experienced "early failures" in a number of expensive systems from large scale computer systems to mil-spec avionics. I would not be inclined to equate such a failure with build quality as that is a distinctly different thing.
    So check with your dealer and work through the variables. Your dealer is there to make things right.
    -bob

  7. #7
    Member
    Join Date
    Nov 2008
    Posts
    171
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by Dan Santoso View Post
    Halo,

    I bought P65 recently and today I had my 3rd photoshoot.

    .....

    For a $45,000 piece of equipment, it sure gave me a shock. It seems the build quality is bad. My $3000 DSLR wont give me this problem after 2-3 years.
    Dan,

    Believe me, I can sympathised with you. It is indeed a "well supported system". Hope your client much more understanding than mine! Good luck.

  8. #8
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Maybe it's just me but I figure that we should have heard something back by now even if it's hey guys I've contacted my dealer and we're working on a solution. I fully understand the frustration that Dan is experiencing however to post this type of post then go dark is questionable.

    I might just be overly grumpy this morning so take this with a grain of salt...

    Don
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  9. #9
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: Big Problem with new P65+

    Unfortunately our GetDPI forum is getting big enough where we are subject to troll posts. These can be folks just trying to create conflict for their own entertainment or shadow members from other companies trying to sabotage a competitor's product. They can usually be linked to posts from members that have very low post counts.

    Alternatively it can be legitimate, but then as Don points out, you normally hear back with more specifics from the OP about the issues. Given that isn't happening here, he could be busy or it could be a possible troll post.

    PS: If anybody has a good "Troll Post" smiley, load it up and we'll choose a good one to add in to our smiley dropdown menu!
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  10. #10
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Not trying to

    It’s sad when we start getting posts like this and our community is willing to help only to find the intent of the original post was not what we thought to be. I also admit to finding it suspect that a seemly professional photographer would post a message such as this without first having gone through his/her dealer. If it quacks like a duck it is probably a duck.

    I welcome Dan to respond and prove me wrong.


    Don
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  11. #11
    Member Arjuna's Avatar
    Join Date
    Mar 2008
    Location
    Calgary, Alberta
    Posts
    203
    Post Thanks / Like

    Re: Big Problem with new P65+

    I appreciate the problem of troll post, but I might cut him a little slack: it has only been 22 hours since the original post, he may not be online continuously - he may not have had time or opportunity to do anything yet.

  12. #12
    Senior Member
    Join Date
    Jun 2009
    Posts
    1,347
    Post Thanks / Like
    Images
    12

    Re: Big Problem with new P65+

    this is a troll post only because it reports of an issue with a Phase One back?
    Strange...

  13. #13
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: Big Problem with new P65+

    No Thomas, a *possible* troll post because it appears to be nothing more than a rant without any substantiation of the issue or responses to the help being offered, at least yet. And in that I agree with Arujna, that we need to give the OP more time to reply.
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

  14. #14
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by thomas View Post
    this is a troll post only because it reports of an issue with a Phase One back?
    Strange...
    I don't look at it that way. I could care less what manufacture he says sucks (my term). It's the fact that this was posted without any reference to what he did to correct the problem ie contacting his dealer.

    We are that naive to thing anyone let along a professional would encounter a problem with any high end system and not immediately contact his dealer first to get support. Why does this person write about the problem and bash the equipment at the same time then ask for assistance here without first contacting his dealer?

    I just clicked on his profile and found he hasn't been logged in for 22 hrs. Doesn't it strike you as strange that a request for help is made and no follow-up?

    Again I could care less whether we're talking about Phase, Hassy, Leaf or whatever; in this case it just happens to be Phase.

    And I'll say this once again - Dan if you are reading this thread you need to realize where we're coming from. Your post is rather suspect on the face of it - it has nothing to do with the brand name.

    I agree with the other comments here and feel we do need to step back and wait a reasonable amount of time.

    Don

    I was writing this the same time Jack was and almost didn't post it.

    I've said all I'm going to on this subject till Dan responds.
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  15. #15
    Member
    Join Date
    Dec 2008
    Posts
    177
    Post Thanks / Like

    Re: Big Problem with new P65+

    I don't really have a dog in this fight, but in defense of folks who don't always go running to their dealers every time they need to blow their nose, I've been using a P-45+ back now for more than three and a half years and have never gone back to my dealer once, even though I have had some serious issues with the back (I bought this back mail order since there are no phase dealers in my part of the country). One reason to join an online community like this one is to be able to look for answers from those who use the same type of equipment (and sometimes vent too). Calling someone a troll just because they did not log back on again for 22 hours is kind of silly - lots of folks have lives outside of internet forums. (Although I must say that I don't since I seem to log in here many times each day!) And good grief, even if he left the most desperate message in the world, perhaps his internet went down or he had to go do something else. No sweat off of your back. This is a very civil forum and I kind of expected more from you guys....

    (Actually I was just thinking this to myself and never really intended to post this - my internet connection was not working at the time but I guess it came back to life and I just now realized it was posted. Same thoughts though, just now out loud, that will teach me!)
    Last edited by Tim Ernst; 3rd September 2010 at 09:02.

  16. #16
    Senior Member
    Join Date
    Nov 2007
    Posts
    498
    Post Thanks / Like
    Images
    8

    Re: Big Problem with new P65+

    Quote Originally Posted by dougpetersonci View Post
    See the Extreme Video series - while humorous and marketing oriented they do correctly - in my experience - represent the construction quality and durable/reliable nature of these backs.


    Holy crap! That said, I have to wonder how the rest of the camera handles the same treatment.

  17. #17
    Senior Member
    Join Date
    Jun 2010
    Posts
    270
    Post Thanks / Like

    Re: Big Problem with new P65+

    Hi Guys,

    Sorry for the response delay. I am not a troll

    I called my local dealer and he told me that the on/off problem could be the power source problem. It seems the camera cant figure out which power I am using.

    Bout the battery problem, he told me to change the power source to battery only. I swear I did it already, but when I try it again, it solves the problem _)))))))


    Another sign before this problem was the camera read my full battery as empty, I suspect this as a bug or the battery connector was not working well.

    I am leaving on a trip to NZ soon, hopefully the camera wont fail me in the next 2 weeks.


    Dan Santoso
    www.dansantoso.com

  18. #18
    Member
    Join Date
    Oct 2009
    Posts
    109
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by Jack Flesher View Post
    PS: If anybody has a good "Troll Post" smiley, load it up and we'll choose a good one to add in to our smiley dropdown menu!
    He, he, perhaps a 'Humble Pie' smiley is in order too!! (just kidding)

    Impressive portfolio of work on your site Dan.

  19. #19
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Dan - very pleased to hear you got the problems fixed and best of luck in NZ.

    Don
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  20. #20
    Senior Member KeithL's Avatar
    Join Date
    May 2008
    Posts
    832
    Post Thanks / Like

    Re: Big Problem with new P65+

    I've got to wonder how many folk here would have suspected a troll had Dan been using anything other than Phase One?

  21. #21
    Senior Member kdphotography's Avatar
    Join Date
    Aug 2008
    Location
    Carmel/Tucson
    Posts
    2,356
    Post Thanks / Like

    Re: Big Problem with new P65+

    Have a great trip to New Zealand----that is a location that is definitely on my to-do list!

  22. #22
    Super Duper
    Senior Member

    Join Date
    May 2008
    Location
    32° 31' 37.06" N, 111° 6' 0.9" W
    Posts
    4,334
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by KeithL View Post
    I've got to wonder how many folk here would have suspected a troll had Dan been using anything other than Phase One?
    I don't feel that way at all. It isn't always about the "brand" but the message content itself.
    Don Libby
    Iron Creek Photography
    Blog
    Tucson AZ

  23. #23
    Senior Member stephengilbert's Avatar
    Join Date
    Nov 2007
    Location
    Santa Monica, CA
    Posts
    2,276
    Post Thanks / Like
    Images
    2

    Re: Big Problem with new P65+

    "I've got to wonder how many folk here would have suspected a troll had Dan been using anything other than Phase One?"

    Right; if he's said his Leica was defective, no one would bat an eye.

  24. #24
    Administrator, Instructor Guy Mancuso's Avatar
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    23,623
    Post Thanks / Like
    Images
    2555

    Re: Big Problem with new P65+

    Dan glad you seemed to have found the issue. I'm on vacation and did not get a chance too respond. But my guess would have been a defective battery. Glad you got it handled.
    Photography is all about experimentation and without it you will never learn art.

    www.guymancusophotography.com

  25. #25
    Member
    Join Date
    Nov 2008
    Posts
    171
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by stephengilbert View Post
    "I've got to wonder how many folk here would have suspected a troll had Dan been using anything other than Phase One?"

    Right; if he's said his Leica was defective, no one would bat an eye.
    ...ouch!

  26. #26
    Subscriber Member jotloob's Avatar
    Join Date
    May 2008
    Location
    KEMPTEN / GERMANY
    Posts
    1,513
    Post Thanks / Like
    Images
    116

    Re: Big Problem with new P65+

    I must say , that I am somewhat surprised , confused and disconcerted about the "troll discussion" .
    I can not understand , that now the discussion goes on , as if nothing has happened . ? ? ?
    Jürgen

  27. #27
    Senior Member etrump's Avatar
    Join Date
    Jan 2009
    Posts
    1,206
    Post Thanks / Like

    Re: Big Problem with new P65+

    Do you have zero latency turned on? Doug Petersen mentioned just yesterday that he back shuts itself off if zero latency causes the sensor to get too hot.

  28. #28
    Senior Member
    Join Date
    Jan 2009
    Location
    College Place, WA.
    Posts
    790
    Post Thanks / Like

    Re: Big Problem with new P65+

    Quote Originally Posted by Aaron View Post
    He, he, perhaps a 'Humble Pie' smiley is in order too!! (just kidding)

    Impressive portfolio of work on your site Dan.
    Very nice portfolio!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •