Site Sponsors
Results 1 to 12 of 12

Thread: RZ67 Pro IID + HX701 + ZD back oddness

  1. #1
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    RZ67 Pro IID + HX701 + ZD back oddness

    Hi, all.

    So i bit the bullet and decided to add IID to my collection of gear (i normally roll with AFD and Aptus 54s and its working out fine, except for glitches in Aptus back that Phase One seems to be unable to fix even after two visits to shop, but oh well).

    So far i tried it with ZD back (its easier to carry about. Leaf is heavier and it sits at home), and there are two things that totally puzzling me

    - orientation is reversed? I.e actual position of back is landscape, but it comes to that position being in "portrait" orientation from camera indication (and thats how viewfinder triggered).. Is it normal or there is something funky going on? Film backs seems to be working correctly.

    - orange light in film advance indicator. Only mode i seem to be able to shoot in is multi-shot (M operation), in normal (white rectangle) it just ignores me and shutter wont release. Is it how this sppse to be or? I cant find any info on this, or i wouldnt be bugging you

    Thanks in advance for any ideas..

  2. #2
    Senior Member darr's Avatar
    Join Date
    Jan 2009
    Location
    North Florida
    Posts
    981
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Quote Originally Posted by SergeiR View Post

    - orientation is reversed? I.e actual position of back is landscape, but it comes to that position being in "portrait" orientation from camera indication (and thats how viewfinder triggered).. Is it normal or there is something funky going on? Film backs seems to be working correctly.
    The orientation is reversed when using a digital back. The solution I found was to upgrade the screen to this:

    http://www.bhphotovideo.com/c/produc...n_Type_A4.html


    Quote Originally Posted by SergeiR View Post
    - orange light in film advance indicator. Only mode i seem to be able to shoot in is multi-shot (M operation), in normal (white rectangle) it just ignores me and shutter wont release. Is it how this sppse to be or? I cant find any info on this, or i wouldnt be bugging you
    You can only shoot in M operation with a digital back.

    So you are correct on both of these findings and nothing is wrong with your RZ IID.

    Darr
    "Creativity takes courage." ~ Henri Matisse
    Darlene Almeda, photoscapes.com

  3. #3
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Thanks, Darlene Huge stone off me shoulders.

    I just got the ProIID last week off ebay auction - whole number (body in good condition + 220back + polaroid back + 110/2.8 + AE prism + rangefinder screen) for roughly more than 900$ and still freaked out a bit - trying to do all testing possible before signing off on this..

    With AFDs it was easy - i been buying them from dealers..

    Anyone, one more question then, if you know this - does it have to make that nasty beeping sound after a while, when shooting in M? As far as i understood its to indicate "hey, i can do multi shot only for so long while keeping shutter"

    I mean i see it works, i.e its not actually keeping shutter open all the time. Pictures appearing on ZD.

    Oh and thanks for hint on screen - i just ordered Brighscreen one. Just will have to think on how to do masking marks when got it. Have it on my AFDIII, love it.

  4. #4
    Senior Member darr's Avatar
    Join Date
    Jan 2009
    Location
    North Florida
    Posts
    981
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Quote Originally Posted by SergeiR View Post

    Anyone, one more question then, if you know this - does it have to make that nasty beeping sound after a while, when shooting in M? As far as i understood its to indicate "hey, i can do multi shot only for so long while keeping shutter"
    I cannot really answer that since mine does not make that sound. I am using a Phase One P45 back. Maybe the ZD back is different? You can call Capture Integration and ask them as I purchased my DB plate from them and Dave was very helpful.

    Overall, I am very happy with my RZ setup for portrait work. Great camera!

    Best,
    Darr
    "Creativity takes courage." ~ Henri Matisse
    Darlene Almeda, photoscapes.com

  5. #5
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    So basically to update, may be it will help someone later

    In part answer was done by Leon on old Leaf forum.

    - in order to use AFD mount Leafs on RZ ProIID all you need is plate HX701 (mamiya one, no clue about leaf number for it).
    - despite what manual will say and what you think is right - back has to be in AFD mode, not RZ.
    - body has to be in multi-exposition mode (switch to M)
    - despite what manual say you totally and utterly do not need connecting funky cord for micro-jack (2.5mm) to PC, to run from lens to back.

    you can fire away, flash triggers from hot shoe quite happily. Same setup would work for ZD backs.

    now if you are unlucky poor bugger like i am, you will start seeing funky stuff when your Aptus will miss frames every now and then. I.e they will be entirely black (with plenty of noise to compliment things).

    Which means - tough, time to send back to service.

    Once my ZD is back from repairs, i will shove Aptus there, and see what they will say.

  6. #6
    Senior Member yaya's Avatar
    Join Date
    Dec 2007
    Location
    London, UK
    Posts
    1,168
    Post Thanks / Like
    Images
    38

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Sergei hi, I replied to your post on our User Forum:

    The more recent Aptus-II backs include both hardware and firmware that improve the communication with the RZIId body (with the Mamiya adapter). This also resolves previous issues with power consumption on the body and correct iso reading.

    This improvement cannot be adopted to the Aptus and Aptus S backs. The workaround can be using the Leaf adapter with a sync cable.


    Hope this helps

    Yair
    Yair Shahar | Product Manager | Phase One | Mamiya Leaf
    e: [email protected] | m: +44(0)77 8992 8199 | yaya's blog

  7. #7
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Thanks, Yair. I totallt forgot to check new leaf forum yesterday - will go there and reply too

    But basically it kinda doesnt help since mine is 54s, which i love except for odd quirks like that. I am not sure how leaf adapter is different from Mamiya one , at least from picture in manual they look fairly close. And i am not quite up for buying another 1k plate after already spending money on Mamiya one (this is one i at least could find. I tried to ask Digital Integrations in Dallas about Leaf one two and half weeks ago - never heard from them - same story as when i was looking to buy back, altough then they replied month after it was bought from Derek).

    I just still think that might be some glitch in board circuit. I mean it is AFD interface, just with less readouts, and it sppse to work with AFD plate. Plus i want service center to fix few things they didnt in April.

  8. #8
    Senior Member yaya's Avatar
    Join Date
    Dec 2007
    Location
    London, UK
    Posts
    1,168
    Post Thanks / Like
    Images
    38

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Quote Originally Posted by SergeiR View Post
    Thanks, Yair. I totallt forgot to check new leaf forum yesterday - will go there and reply too

    But basically it kinda doesnt help since mine is 54s, which i love except for odd quirks like that. I am not sure how leaf adapter is different from Mamiya one , at least from picture in manual they look fairly close. And i am not quite up for buying another 1k plate after already spending money on Mamiya one (this is one i at least could find. I tried to ask Digital Integrations in Dallas about Leaf one two and half weeks ago - never heard from them - same story as when i was looking to buy back, altough then they replied month after it was bought from Derek).

    I just still think that might be some glitch in board circuit. I mean it is AFD interface, just with less readouts, and it sppse to work with AFD plate. Plus i want service center to fix few things they didnt in April.
    Sorry for the trouble Sergei. In Texas you can speak to Ivan at
    Digital Transitions.

    The Leaf adapter is mechanical which means there's no electronic connection between the back and the body and the back needs to be set for RZ and use a sync cable from the lens. This has proved to be a solid and reliable setup with many customers over the years. The part number that is suitable for your A54S is 518-02210A and it comes with a marked focusing screen and a sync cable

    You're welcome to send your back in for service/ clean but we won't be able to resolve the dark frames issue.

    Yair
    Yair Shahar | Product Manager | Phase One | Mamiya Leaf
    e: [email protected] | m: +44(0)77 8992 8199 | yaya's blog

  9. #9
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Hmm.. Thanks, its not trouble Its just more of annoyance and may be i am just ought to sell ZD , Aptus 54s and couple of spare AFD bodies and spring for Aptus][ which then would serve me on AFDIII and IID both

    Thanks for part number. I will try to give them a buzz and see what i can find out.

    (oh it was Digital Transitions, not Integrations that i tried to contact via support mail, bugger.. i keep messing up names - i just dont like to call, prefer to do emails first)

  10. #10
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    Right. After some tinkering i solved/figured how to get Mamiya's plate to work with Leaf older backs (pre II ones, i presume) without spending extra money and keep digital compatibility for future upgrades and keep camera from being hacked and never being able to shoot film.

    Need - 5 minutes with dremmel and piece of dielectric tape handy. And you will need cable to run from lens to back, of course. Nothing special, any MICRO (not mini)-jack to PC will do. Pretty coiled ones will be like 28$, you can use one that sold as "mamiya cable for DL/DM backs..".

    Multi shot operation on RZs is blocked when Mamiya plate is attached, and apparently not blocked with Leaf one. It happens b/c plate presses in one of mechanical sensors - so camera expects signal exchange.. but there is no such signal from older Leaf backs, alas. There is, however from ZD, which indicates there is same from newer Leaf backs.

    So.
    1) we switching back to RZ mode (ability to operate your Aptus in AFD mode with that plate is in fact just a glitch, and it wont work correctly with flash, and it will have funky problems with no catching shutter in time every now and then).

    if you attach plate and back now to RZ - it will beep and scream and refuse to shoot.

    2) remove back from plate, grab dremmel or electric drill, if you feel sure about your ability to control drill. You need bit that is about 3-4 mm wide. Dremmel has nice attachment that looks like small ball with very sharp blades. Go somewhere where you can sit / lay comfy. Note the wee ball on the lower left (you facing back of camera), right above vertical row of electrical connections. This is wee bugger that stops you. Second one (there is another one on the right) - you can ignore. align plate to see where this will touch (contacts to contacts - spot should be right above those contacts). Take out wee bit of metal so this ball will not be fully pressed in. Its about 1-2 mm.. Watch out to not drill all the way through plate.

    3) clean shavings throughly. Put back on plate. Attach cable. Try to fire. Camera will complain a bit again. Hence - some electrical current travelling. Take back off, tape contacts on the bottom. Press back onto plate again, reattach ...

    4) you good to roll.. You RZ Pro IID body fully working with HX701 and early Leaf backs, yet, if you want to shoot film - it can do it, b/c you didnt damage anything.. and it still can operate in AFD mode - we didnt damage any circuitry

  11. #11
    Senior Member
    Join Date
    Dec 2008
    Location
    Los Gatos, CA
    Posts
    340
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    LOL...coincidentally, I just finished building a "Phase One-Shot Wireless Trigger" for my RZ67 with Phase back and Leaf plate. My Leaf plate came with the electronic cable with the 6-pin phone/ethernet-style cable to plug into a Leaf back.

    But my Phase uses a stereo plug (for wake-up), so I wired an ethernet jack to a stereo plug and a remote port for my Minolta wireless trigger.

    Now, the half-press (which normally focuses my A700) triggers the back, and full-press triggers the camera. AND it's RF-wireless...so no LOS is even necessary.

    You'd think if Phase can sell a One-shot cable for $400, they'd try to come up with something like this for, say, $1000.

  12. #12
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: RZ67 Pro IID + HX701 + ZD back oddness

    I think we need to start putting together thread on small DIY hacks )

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •