Site Sponsors
Results 1 to 8 of 8

Thread: Problem Charging Batteries on Leaf Aptus

  1. #1
    Senior Member
    Join Date
    Nov 2010
    Posts
    622
    Post Thanks / Like
    Images
    5

    Problem Charging Batteries on Leaf Aptus

    What does it mean when the charger for the battery stays RED all the time? I am trying to charge the Batteries that came with my Leaf Aptus 22 . I dont know if its the batteries or the charger. Any suggestions? I am using the Hahnel MCL 103 charger and Leaf battery 2350 mah batteries( 2)

  2. #2
    Senior Member
    Join Date
    Sep 2010
    Location
    Dallas/Novosibirsk
    Posts
    632
    Post Thanks / Like

    Re: Problem Charging Batteries on Leaf Aptus

    Battery might have died. I have original leaf battery that did this. Cant charge it anymore.

  3. #3
    Senior Member yaya's Avatar
    Join Date
    Dec 2007
    Location
    London, UK
    Posts
    1,168
    Post Thanks / Like
    Images
    38

    Re: Problem Charging Batteries on Leaf Aptus

    Constant Red means a fault. If it does it with both batteries then it could be the charger
    Yair Shahar | Product Manager | Phase One | Mamiya Leaf
    e: [email protected] | m: +44(0)77 8992 8199 | yaya's blog

  4. #4
    Senior Member
    Join Date
    Nov 2010
    Posts
    622
    Post Thanks / Like
    Images
    5

    Re: Problem Charging Batteries on Leaf Aptus

    I just might have to order a NEW charger and Battery. Thank you

  5. #5
    Member
    Join Date
    Mar 2011
    Posts
    173
    Post Thanks / Like

    Re: Problem Charging Batteries on Leaf Aptus

    I had what seems like the same problem. It turned out that the charger was not getting power because of a contact problem with the plug. Applying (constant) lateral pressure to the plug solved my problem. I wrapped the cable around the rear plastic bit a few times then tied it, its not pretty but works. You can test if the charger is getting power by looking at the red LED. I suggest placing the battery in the charger without the power supply connected in a dim area first, then plugging it in. The LED should glow brighter if it is receiving power. Good luck!

  6. #6
    Senior Member
    Join Date
    Nov 2010
    Posts
    622
    Post Thanks / Like
    Images
    5

    Re: Problem Charging Batteries on Leaf Aptus

    I did push in and do all that you said and the battery must be dead. 1 of the batteries I received ( used) when I purchased the camera afew weeks ago must be totally dead. The red light wont come on at all for that one. The other battery has a constant red lit up. I will have to order a new battery and a Twin Charger( Hahnel) from Capture Integration. Hopefully then it will work. Thank you, rollsman

  7. #7
    Member
    Join Date
    Mar 2011
    Posts
    173
    Post Thanks / Like

    Re: Problem Charging Batteries on Leaf Aptus

    That is quite strange. What happens when you use the batteries on the back?

  8. #8
    Senior Member
    Join Date
    Nov 2010
    Posts
    622
    Post Thanks / Like
    Images
    5

    Re: Problem Charging Batteries on Leaf Aptus

    The back will does not power on. What happens is the yellow light comes on for a few seconds then it shuts off. Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •