Site Sponsors
Results 1 to 4 of 4

Thread: Phase ONe 645DF cable release socket loose

  1. #1
    Member
    Join Date
    Apr 2010
    Posts
    116
    Post Thanks / Like

    Phase ONe 645DF cable release socket loose

    My 645DF is just under 2 years old and nearly all of my pictures are made on a tripod with the cable release attached to the socket on the LHS of camera body instead of the one on the P45+ back.

    Play has developed whereby the socket moves around in the camera body. Currently I estimate there to be about 1mm of travel. It looks like it's a retaining nut worked loose or some other retaining device.

    I did do a search, but couldn't find anything posted here of anyone reporting such a problem. Has anyone else had experience of this?

    I'm thinking that it needs to go back to the dealer, but open to cheaper suggestions please on how to rectify the problem!

  2. #2
    Member
    Join Date
    Apr 2010
    Posts
    116
    Post Thanks / Like

    Re: Phase ONe 645DF cable release socket loose

    Looks like I am the only one with this issue. That's good to know, I'm just not looking forward to the repair bill!

  3. #3
    Senior Member etrump's Avatar
    Join Date
    Jan 2009
    Posts
    1,206
    Post Thanks / Like

    Re: Phase ONe 645DF cable release socket loose

    My p65 synch socket came lose once. I sent it to phase and they corrected no charge.

  4. #4
    Member
    Join Date
    Apr 2010
    Posts
    116
    Post Thanks / Like

    Re: Phase ONe 645DF cable release socket loose

    Thanks Ed. My dealer seems to think that I will have to cough up something like 100-300. No charge is much more preferable!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •