Site Sponsors
Results 1 to 4 of 4

Thread: Problem with Hasselblad CF Adapter

  1. #1
    Senior Member
    Join Date
    Jan 2010
    Posts
    381
    Post Thanks / Like

    Problem with Hasselblad CF Adapter

    I am currently using a CF adapter on my H4D 60. The lens is a Zeiss 40 mm CFE IF (a magnificent lens). I keep getting an error message after shooting - "Lens cocking error." When I hit "ok," it says,"Cock the Lens." That works fine and I able to shoot again. The interesting thing is that the images are fine, just the extra step of clicking "ok" on the error message. Anyone have any issues like this? Thank you.

  2. #2
    Senior Member Swissblad's Avatar
    Join Date
    Oct 2011
    Posts
    1,204
    Post Thanks / Like

    Re: Problem with Hasselblad CF Adapter

    I'm not sure that I understand your problem correctly.
    In my experience, the cocking lever on the CF adapter may need to be engaged 2x, as the 1st pull is insufficient to cock the V lens.
    This can be a frequent issue - I pay little attention to it - just re-cock.
    Enjoy your new toy!

  3. #3
    OJO
    Guest

    Re: Problem with Hasselblad CF Adapter

    Send it to Hasselblad service.

  4. #4
    Member
    Join Date
    Aug 2012
    Location
    Singapore
    Posts
    32
    Post Thanks / Like

    Re: Problem with Hasselblad CF Adapter

    I've had this message a couple of times on my h4d-50 a while ago but they don't appear anymore. I guess some ethanol contacts cleaning should help

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •