Site Sponsors
Results 1 to 9 of 9

Thread: Hasselblad 500cm won't fire unless lens tweaked

  1. #1
    Member
    Join Date
    May 2013
    Posts
    38
    Post Thanks / Like

    Hasselblad 500cm won't fire unless lens tweaked

    Got my new old 500cm sometimes when I hit the shutter release it does nothing but click. Still can see from the waste level. Have to tweak my lens and it clicks again. Blocking viewfinder image then I can take the shot.

    Why?! This has taken many images away from me today so far.

    Anyone have ideas?

    Help! Thanks in advance!

  2. #2
    Member
    Join Date
    May 2013
    Posts
    38
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    Does it at random it seems and with both of my lenses.

  3. #3
    Super Duper
    Senior Member
    Godfrey's Avatar
    Join Date
    Jan 2009
    Location
    Near San Jose, California
    Posts
    7,930
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    It may need a service. The person to ask is Dave Odess: Hasselblad camera repair, service, and sales by factory trained technician David Odess.

  4. #4
    Member
    Join Date
    May 2013
    Posts
    38
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    It's related to the mirror up function. It's semi arming the film back but not the body when walking around it seems.

    Then they aren't in unison and I have to turn the lens to get the body where the film back is.

    Any suggestions, can I disable mirror up? Seems connected to the shutter release.

  5. #5
    Member schuster's Avatar
    Join Date
    Mar 2011
    Location
    New Hampshire, US
    Posts
    130
    Post Thanks / Like
    Images
    11

    Re: Hasselblad 500cm won't fire unless lens tweaked

    Quote Originally Posted by Kjarahz View Post
    Got my new old 500cm sometimes when I hit the shutter release it does nothing but click. Still can see from the waste level. Have to tweak my lens and it clicks again. Blocking viewfinder image then I can take the shot.
    Describe what you do when you "tweak" the lens.

    Looking through the front of the lens, can you see the shutter opening and closing or is something else clicking?

    What happens if you take the film magazine off the camera and then press the shutter release?

  6. #6
    Member Douglas Fairbank's Avatar
    Join Date
    May 2012
    Location
    London
    Posts
    35
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    Based on your description the latch on the lens that holds the loading key is not being freed and 'tweeking' the lens is just enough to trip it.
    Get the lens and body checked, it should be a simple fix.
    Classic V, support for Hasselblad V system cameras.
    www.classicv.co.uk

  7. #7
    Member
    Join Date
    May 2013
    Posts
    38
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    Tweak, I twist the lens to the left ever slightly and the mirror locks up after.

    Happens with two a12 backs. And two lenses. The pin that operates the mirror lock up seems to engage sometimes but not fully. The shutter depresses without anything happening. That's when I know it screwed up and in is in mirror lockup without me tripping it. Tweak the lens the mirror flops up can't see crap but can't take an exposure.

    Hope that helps someone shed some light. Off to shoot more today right now. Will try more of the 80mm since my 150 did it a lot. Every 3-4 pictures.

    I contacted David any help in the mean time would be fantastic. Huge trip in two weeks. I need a fix before then naturally.

    Please disregard typos this was written on an iPhone.

  8. #8
    Senior Member johnnygoesdigital's Avatar
    Join Date
    Mar 2010
    Posts
    1,579
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    Never take the lens off/on unless the shutter is cocked. Confirm the alignment of the lens and body is correct by looking at the pins. The MU button could be sticky, so work it up/down, and fire a few frames with no lens or film back. The camera might need a CLA and David Odess has a great reputation. Prices are such for a 500cm, that a back up camera might be a wise investment.

  9. #9
    Member
    Join Date
    May 2013
    Posts
    38
    Post Thanks / Like

    Re: Hasselblad 500cm won't fire unless lens tweaked

    I was thinking of grabbing a backup camera but was concerned, is it definitely a body issue?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •