Site Sponsors
Results 1 to 5 of 5

Thread: RZ67 Pro II + Aptus II + AE Prism

  1. #1
    New Member
    Join Date
    Jun 2014
    Posts
    4
    Post Thanks / Like

    RZ67 Pro II + Aptus II + AE Prism

    I have a RZ67 Pro II, Aptus II 5 and the Mamiya AE Prism II. I ran into a few quirky things and was wondering if anyone can provide some insight.

    Is the AE Prism compatible with digital back? In other words does the digital back relay the ISO to the Prism? The prism is metering but regardless of what ISO is entered it doesn't exposure properly. It look like its off by 3-4 stops.

    When taking a picture I noticed that the ISO, aperture and shutter speed is recorded. However the shutter speed is not correct. Can the RZ67 Pro II relay the shutter speed to the digital back?

    Any help, fix or insight is greatly appreciated.

  2. #2
    Member
    Join Date
    Dec 2010
    Location
    Southern California
    Posts
    141
    Post Thanks / Like
    Images
    21

    Re: RZ67 Pro II + Aptus II + AE Prism

    If the on switch around the shutter release button isn't on, you always get 1/400 second shutter speed. Make sure that is on. And the shutter dial on the camera body should be set to AEF. Then the shutter dial on the AE Prism Finder II will take over, which should also be on A for Auto. The little dial to the left should be on zero for exposure compensation.

    The back will send the ISO speed to the prism. It only has aperture priority. Set the aperture on the lens. With the shutter dial on the AE Prism on auto, it will select a shutter speed for you, which you can see in the viewfinder, on the left side. It should work right, unless you have a low battery.

    The shutter speed is not recorded correctly on the back in auto exposure mode. Try selecting a shutter speed on the top dial. Then take a picture and it is recorded correctly.

    --Steve.

  3. #3
    New Member
    Join Date
    Jun 2014
    Posts
    4
    Post Thanks / Like

    Re: RZ67 Pro II + Aptus II + AE Prism

    thanks Steve! I'm doing all that already. The only thing that it could be is the RZ67 needs a new battery. I'll follow up with the results.

  4. #4
    Senior Member yaya's Avatar
    Join Date
    Dec 2007
    Location
    London, UK
    Posts
    1,168
    Post Thanks / Like
    Images
    38

    Re: RZ67 Pro II + Aptus II + AE Prism

    Quote Originally Posted by rodal126 View Post
    thanks Steve! I'm doing all that already. The only thing that it could be is the RZ67 needs a new battery. I'll follow up with the results.
    Is this an RZII or a Iid? If the firmware then aperture will not be recorded/ transmitted and the shutter sped that is recorded comes from the X-sync on the lens. There is no communication between the back and the prism in that case.

    BR

    Yair
    Yair Shahar | Product Manager | Phase One | Mamiya Leaf
    e: [email protected] | m: +44(0)77 8992 8199 | yaya's blog

  5. #5
    Member
    Join Date
    Dec 2010
    Location
    Southern California
    Posts
    141
    Post Thanks / Like
    Images
    21

    Re: RZ67 Pro II + Aptus II + AE Prism

    I think he meant "if the former" rather than "If the firmware."
    So, only an RZ67 PRO II D transmits the ISO speed from the back to the prism? That's the one I have, and I haven't tried the Pro II (non D).

    Sounds like you need to get a light meter for now.


    --Steve.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •