Site Sponsors
Results 1 to 2 of 2

Thread: Shutter Lock Up on Mamiya AFD III with Film backs

  1. #1
    Member justin989's Avatar
    Join Date
    Oct 2008
    Location
    New York, NY
    Posts
    60
    Post Thanks / Like
    Images
    12

    Shutter Lock Up on Mamiya AFD III with Film backs

    So I have been using my afdIII with the film backs from my old AFD II as they are compatible. However, after I go through a roll of 120, take it out and pop in another roll and advance to the first frame, the shutter doesn't actuate! I can still autofocus but no matter how many times I press the shutter button, it won't fire. This has happened to me everytime....the only way I can actuate the shutter again is when I put my digital back on and fire off some shots, then it appears to go back to normal working condition


    Has anyone had a similar experience? Im not sure if this is a firmware bug, I checked and the firmware is version 1.1

    WTF!!

    regards,

    -j

  2. #2
    Sr. Administrator Jack's Avatar
    Join Date
    Oct 2007
    Location
    Los Altos, CA
    Posts
    10,486
    Post Thanks / Like
    Images
    1031

    Re: Shutter Lock Up on Mamiya AFD III with Film backs

    Not sure, but check to make sure the battery in the film back is good. Other possibility is the dark slide release pin may be sticking?
    Jack
    home: www.getdpi.com

    "Perfection is not attainable. But if we chase perfection, we can catch excellence."

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •