Site Sponsors
Results 1 to 6 of 6

Thread: Hasselblad H5D-50 magenta cast problem

  1. #1
    New Member
    Join Date
    Jul 2015
    Posts
    3
    Post Thanks / Like

    Hasselblad H5D-50 magenta cast problem

    I have a 7 month old Hasselblad H5D-50 (ccd version) camera/back that I also shoot on a Cambo WRS tech camera. I have never had a problem with the back up until earlier this week when the back started showing a magenta cast gradating from the left side of the image. This is NOT due to the tech camera movements as it also appears when shot on the H5D body. It also happens at all shutter speeds, apertures and ISO settings.

    I am using the current firmware on the back (2.5.4R) and have also tried it with the legacy firmware - same problem exists.

    This same problem happened to me last year with a rental H5D-50

    I have put calls and emails into Hasselblad tech support but have not heard anything back yet.

    Has anyone else seen this problem and know how to fix it?

    thanks, ryan

    image sample here:
    Name:  H5D-50_test_0001.jpg
Views: 466
Size:  175.0 KBName:  H5D-50_test_0001_close.jpg
Views: 454
Size:  32.5 KB

  2. #2
    New Member
    Join Date
    Jul 2015
    Posts
    3
    Post Thanks / Like

    Re: Hasselblad H5D-50 magenta cast problem

    I heard back from Hasselblad today. It seems the back has to be sent in for repair. Oh well...

  3. #3
    New Member
    Join Date
    Jul 2015
    Posts
    7
    Post Thanks / Like

    Re: Hasselblad H5D-50 magenta cast problem

    Bad news for you. Fortunately your camera is still on warranty. You have to contact your dealer and your camera has to go back to Sweden, because the sensor must be replaced. I had exactly the same problem, and I had to wait almost two months to get it back, because it was end of July (like now) - holidays. Sorry for you.

  4. #4
    Senior Member stngoldberg's Avatar
    Join Date
    Apr 2011
    Location
    newport, RI
    Posts
    808
    Post Thanks / Like
    Images
    12

    Re: Hasselblad H5D-50 magenta cast problem

    Your dealer should give you a loaner while your camera is being repaired...mine did
    Stanley

  5. #5
    Member
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    96
    Post Thanks / Like

    Re: Hasselblad H5D-50 magenta cast problem

    Looks like a light leak to me.

  6. #6
    New Member
    Join Date
    Jul 2015
    Posts
    3
    Post Thanks / Like

    Re: Hasselblad H5D-50 magenta cast problem

    Quote Originally Posted by Anna Engel View Post
    Bad news for you. Fortunately your camera is still on warranty. You have to contact your dealer and your camera has to go back to Sweden, because the sensor must be replaced. I had exactly the same problem, and I had to wait almost two months to get it back, because it was end of July (like now) - holidays. Sorry for you.
    Thanks Anna. I am sending the camera back to Hasselblad today for a warranty repair. It sounds like it needs to go to Sweden. They are sending me a loaner in the meantime.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •