Site Sponsors
Results 1 to 3 of 3

Thread: Help with manual lenses on Sony a850

  1. #1
    Member
    Join Date
    Mar 2008
    Location
    Pacific NW
    Posts
    158
    Post Thanks / Like

    Help with manual lenses on Sony a850

    Hello! I bought an adapter for an old Zuiko 50 1.4 lens and want to use it on my Sony a850. The adapter mounts fine. There are no electrical contacts so the camera thinks there is no lens attached and will not fire the shutter. I can not find out how to disable/enable that function in the menu settings. I read on internet blogs that it is easily done with other Sony cameras. Perhaps this can not be done on the new a850? thanks -rob

  2. #2
    Senior Member douglasf13's Avatar
    Join Date
    Dec 2008
    Location
    Los Angeles, California, USA
    Posts
    1,965
    Post Thanks / Like
    Images
    1

    Re: Help with manual lenses on Sony a850

    The last Sony camera that was able to disable this was the A700. You will have to shoot in M mode if you use a lens without the lens contacts.

  3. #3
    Member
    Join Date
    Apr 2009
    Posts
    98
    Post Thanks / Like

    Re: Help with manual lenses on Sony a850

    On older Sony cameras there was a menu option to choose "Release without Lens" - Y/N option, unfortunately, it is not available on A850/A900.
    You can, however, put the camera in full manual mode and it should ignore the presence of manual lens. You can use the builtin meter but no A mode or S mode, and stop down metering only.

    You can "chip" the adaptor or use a chipped adaptor (search the threads here for more)

    Cheers,

    N
    A and E mount Too many lenses.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •