Site Sponsors
Results 1 to 3 of 3

Thread: Faulty RX1 Lens

  1. #1
    Member
    Join Date
    Aug 2012
    Location
    England
    Posts
    54
    Post Thanks / Like

    Faulty RX1 Lens

    Hi folks,

    Long time no post.

    Wanted to share my current experience.

    I own an RX1. As of a few weeks back I noticed that the aperture ring had some play from front to back, maybe a couple of MM. The focus ring was also grittier than it used to be.

    I took the camera to the Sony shop in Causeway Bay HK, It's still under warranty. After initially pointing at a dink on the bottom corner of the body I made it clear that I had not bashed the lens (I'm sure they could see if i had)

    2 days later after a few calls to confirm what i thought was wrong, today and they have called to say they are replacing the barrel including aperture and focus rings under warranty and it should be ready tomorrow!

    Its good when warranties actually work ;-)

    Lets hope they come through as promised.

    Best regards,
    Rich

  2. #2
    Member
    Join Date
    Aug 2012
    Location
    England
    Posts
    54
    Post Thanks / Like

    Re: Faulty RX1 Lens

    It's fixed.

    This forum isn't terribly chatty but hopefully someone will find this one day when searching for faulty aperture rings etc.

    </public service>
    :-)

  3. #3
    Member
    Join Date
    May 2009
    Location
    Melbourne, Australia
    Posts
    65
    Post Thanks / Like

    Re: Faulty RX1 Lens

    Glad to see it turned out well, rich_. And it's good to see another happy Hong Kong shooter!

    I'm afraid that, with the A7R getting so much attention, you won't get a lot of response around here for a little while. It's a bit like walking into a bar when the football final is on TV, and asking what the crowd thinks about hockey. Nettar

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •