I am not sure if anyone is still using Techart Contax G adapters, as I couldn't find any recent posts almost anywhere on the web. I know they are quirky, but still wanted to check if the problems that I am having are specific to my copy or are known bugs.

As soon as I got the adapter I successfully updated to the latest version of the firmware (2.20) with the Techart iOS app. The adapter mostly works fine on my A7II but here are my issues.

1) Contax G 35: problems with the lens recognition. When the battery is fresh (100%) the adapter correctly identifies it, but as soon as the percentage drops a bit (say 87%) it starts to mix it up with Contax G 28. Sometimes it corrects back to G 35, but after going to sleep or after turning the camera off and on again, the adapter thinks that the attached lens is G 28. I tried to unmount the lens and/or the adapter, and sometimes (but not always) this corrects the issue, but only to revert back to G 28 after going to sleep.

No problems like that with my G 45 and G 90 lenses. Also, not such problems with G 35 on version 2 of the Techart adapter TA-GE1B.

I was wondering if anyone has experienced this.

2) F/ functions. Shooting with the adapter at F25, theoretically, should put it in all-time manual mode. That's how it works on my TA-GE1B adapter, and should also work on TA-GA3 according to operating instructions that I found on the web. However, shooting at F25 does nothing. Also, supposedly shooting at apertures F29-F81 should micro adjust the focusing, but it doesn't seem to do anything (it does on my copy of TA-GE1B).

Can anyone confirm?

3) Contrast AF. This works terribly on A7II and most of the time cannot even lock the focus. (but this works wonderfully on TA-GE1B). Phase detect AF works fine actually, but it is limited to a rather small area on A7II, so I tried switching to Contrast AF outside that area, but the results are terrible. Still, manual focusing works.

4) Focusing with G 90. It the lens is initially focused on a close object and I try to focus on a farther object, the AF does nothing, it seems. But if I prefocus a bit with the manual wheel, then AF can finish the job just fine.

Is this the typical behavior?

Thanks for any insights you could share.