Site Sponsors
Results 1 to 11 of 11

Thread: Had a technical problem with my a900 today

  1. #1
    Subscriber Member mwalker's Avatar
    Join Date
    Dec 2007
    Location
    Kentucky
    Posts
    924
    Post Thanks / Like
    Images
    74

    Had a technical problem with my a900 today

    I was shooting a track meet and when I filled up one CF card I inserted another and the electronics shut down. I couldn't access the menu or anything. I removed the battery and tried another nothing. I tried the original CF card nothing...off it goes to the manufacture I guess. I'll fill everyone in on their service. Anyone else have this problem?

    I didn't take a spare camera (big mistake) but another photographer bailed me out.
    Mike

    website under construction

  2. #2
    Senior Member edwardkaraa's Avatar
    Join Date
    Feb 2009
    Location
    Bangkok
    Posts
    1,470
    Post Thanks / Like

    Re: Had a technical problem with my a900 today

    Sorry to hear about that Mike. Did you switch off the camera before removing the card? Not sure about the Sony but my 1Ds used to switch off automatically when I opened the CF door.
    M262 ZM 25/2.8 35/1.4 50/2 85/2

  3. #3
    Subscriber Member mwalker's Avatar
    Join Date
    Dec 2007
    Location
    Kentucky
    Posts
    924
    Post Thanks / Like
    Images
    74

    Re: Had a technical problem with my a900 today

    Quote Originally Posted by edwardkaraa View Post
    Sorry to hear about that Mike. Did you switch off the camera before removing the card? Not sure about the Sony but my 1Ds used to switch off automatically when I opened the CF door.
    No probably didn't
    Mike

    website under construction

  4. #4
    Super Duper
    Senior Member

    Join Date
    Nov 2007
    Location
    Royal Oak, MI and Palm Harbor, FL
    Posts
    8,498
    Post Thanks / Like
    Images
    44

    Re: Had a technical problem with my a900 today

    Let it sit over night with the battery out, charge a different battery all night, use a different CF card, take two asprins and call us in the morning ... : -)

    I've had a Canon 5D do that to me, and a Nikon D1X did the same thing years ago. Both worked the next day.

    The only reason this happened is because you didn't have a back-up ... Murphy's Law.

    Fingers crossed for you.

    -Marc

  5. #5
    Senior Member edwardkaraa's Avatar
    Join Date
    Feb 2009
    Location
    Bangkok
    Posts
    1,470
    Post Thanks / Like

    Re: Had a technical problem with my a900 today

    Quote Originally Posted by fotografz View Post

    The only reason this happened is because you didn't have a back-up ... Murphy's Law.


    -Marc
    I like this one
    M262 ZM 25/2.8 35/1.4 50/2 85/2

  6. #6
    Subscriber Member mwalker's Avatar
    Join Date
    Dec 2007
    Location
    Kentucky
    Posts
    924
    Post Thanks / Like
    Images
    74

    Re: Had a technical problem with my a900 today

    Ok we'll test Sony's service. Today I "live chatted" with a technical person then he called me and we determined that my a900 is in fact fried. He assigned me a work order number and a priority ID and I sent the camera to their service center in Laredo TX. They said they would try to have it back to me before this weekend as long as I paid for the overnight charges.
    If they do that, it would be A+ service, four day turn around, even if I get it early next week it would be very good. We'll see...I will keep you posted.
    Mike

    website under construction

  7. #7
    Super Duper
    Senior Member
    jonoslack's Avatar
    Join Date
    Nov 2007
    Location
    East Anglia & Cornwall (UK)
    Posts
    11,778
    Post Thanks / Like
    Images
    1

    Re: Had a technical problem with my a900 today

    Quote Originally Posted by mwalker View Post
    Ok we'll test Sony's service. Today I "live chatted" with a technical person then he called me and we determined that my a900 is in fact fried. He assigned me a work order number and a priority ID and I sent the camera to their service center in Laredo TX. They said they would try to have it back to me before this weekend as long as I paid for the overnight charges.
    If they do that, it would be A+ service, four day turn around, even if I get it early next week it would be very good. We'll see...I will keep you posted.
    Mike I'm really sorry - you're the first person I've seen with a dead A900.
    It WILL be interesting to see how well they respond.

    Good Luck and Commiserations

    Just this guy you know

  8. #8
    Subscriber Member mwalker's Avatar
    Join Date
    Dec 2007
    Location
    Kentucky
    Posts
    924
    Post Thanks / Like
    Images
    74

    Re: Had a technical problem with my a900 today

    UPDATE
    Talked with Sony, it was shipped back to me today (three day), total turnaround 6 business days including shipping both ways! Thats about as good as it gets! All the guy could tell me was they replaced a part on the board, made a few adjustments and tested it....

    FYI- the priory service number is 239-768-7606 and the service center number is 866-357-6230
    Last edited by mwalker; 26th May 2009 at 08:48.
    Mike

    website under construction

  9. #9
    Senior Member edwardkaraa's Avatar
    Join Date
    Feb 2009
    Location
    Bangkok
    Posts
    1,470
    Post Thanks / Like

    Re: Had a technical problem with my a900 today

    All good news, Mike. Please keep us updated. In my experience, Sony service has been exemplary so far. For them, coming to a Sony shop with an A900 or a ZA lens is like being a member of CPS
    M262 ZM 25/2.8 35/1.4 50/2 85/2

  10. #10
    Senior Member dhsimmonds's Avatar
    Join Date
    Dec 2007
    Location
    Hampshire, UK
    Posts
    904
    Post Thanks / Like
    Images
    20

    Re: Had a technical problem with my a900 today

    Quote Originally Posted by mwalker View Post
    UPDATE
    Talked with Sony, it was shipped back to me today (three day), total turnaround 6 business days including shipping both ways! Thats about as good as it gets! All the guy could tell me was they replaced a part on the board, made a few adjustments and tested it....

    FYI- the priory service number is 239-768-7606 and the service center number is 866-357-6230
    This is good to know, although I am sorry that you had all the hassle in the first place. Many thanks for sharing what appears to be a very isolated incident with us.
    Cheers, Dave
    www.simmondsphotography.com

  11. #11
    Administrator, Instructor Guy Mancuso's Avatar
    Join Date
    Oct 2007
    Location
    Arizona
    Posts
    23,623
    Post Thanks / Like
    Images
    2555

    Re: Had a technical problem with my a900 today

    Nice turn time Mike.
    Photography is all about experimentation and without it you will never learn art.

    www.guymancusophotography.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •