I recently bought a Chinese made timer remote from eBay for my Panny G2. Last night, I inserted brand new AAA batteries into the remote and connected it to the camera but after pressing the release button, the camera's shutter would not fire. There is unlikely to be any issue with the AAA batteries because the remote's LCD panel is active with all the various digits showing. I also tried the self-timer feature and I could see the digits counting down and the red and green lights flashing on the remote but the camera's shutter still wouldn't fire. I removed the remote and reinserted it but this did not make any difference.

I decided to give it another go this morning and it worked. The remote's shutter release button, the self timer and the interval timer all worked in conjunction with the camera's shutter. I hope that it's not going to be an on-and-off kind of thing with this device where I just have to be lucky whether it's going to work or not when I plug it in. Anybody have any theories as to why the remote didn't work the first time around? I guess it's something to do with electronics but I know nothing about this field.