Site Sponsors
Results 1 to 3 of 3

Thread: Panasonic G1 Built in flash Problem

  1. #1

    Panasonic G1 Built in flash Problem

    Hi All

    I am having a problem with my G1's built in flash. Basically, it doesn't work regardless of which mode I put the camera in even if I set it to "Forced Flash". When I press the shutter, the flash icon would blink red and won't fire. I have tried recharging the battery to full cause the manual says a blinking red icon means the flash is still charging so I thought maybe the battery didn't have enough juice. But still the same after recharging the battery.

    Has anyone seen this before ? Any settings that I may have accidentally changed that caused this ? Any inputs would be appreciated. Thank you

  2. #2
    Senior Member
    Join Date
    Dec 2008
    North Carolina western foothills
    Post Thanks / Like

    Re: Panasonic G1 Built in flash Problem

    I remember seeing just a few issues along these lines when the G1 first came out. As I recall, they had to send the camera in. I don't use the onboard flash so can't comment on that.

    I'm assuming that you have raised the flash though. That was a problem for several people--expecting the flash to raise and go off--but hadn't actually physically raised the flash. You must do this first.


  3. #3

    Re: Panasonic G1 Built in flash Problem

    Yes I did raise the flash. It was working fine the other day and the problem just started last night.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts