The GetDPI Photography Forum

Great to see you here. Join our insightful photographic forum today and start tapping into a huge wealth of photographic knowledge. Completing our simple registration process will allow you to gain access to exclusive content, add your own topics and posts, share your work and connect with other members through your own private inbox! And don’t forget to say hi!

  • Recently, there has been an increased activity from spammers, which may result in you receiving unwanted private messages. We are working hard to limit this activity.

Registration problem with Epson 3880

D Fuller

New member
I have a 10-year-old Epson 3880 that seems to be printing what looks like an echo in prints. For example in a print with small images of boats in the background, the masts will appear to be printed twice. Printing primarily on Ilford Smooth Pearl.

Alignment check prints and nozzle checks seem fine, oddly enough. And I’ve done head alignment on the printer several times, both manually and the auto mode alignment. And both from the printer's control panel and from the Mac's driver.

In a recent development, it has deposited some ink smears of black ink outside the printed area. (Probably a completely separate problem.)

The first image shows the alignment issue. It's a 1-1 macro shot of the print shown in the second image.DSC_0161.JPG

Below, you can see the smearing issue. (White balance on these jpegs is not great, but that doesn't relate to the issue shown.)
DSC_0165.JPG

Does anyone have any idea what’s going on? Has this printer reached end of life?
 

archiM44

Member
I have a 10-year-old Epson 3880 that seems to be printing what looks like an echo in prints. For example in a print with small images of boats in the background, the masts will appear to be printed twice. Printing primarily on Ilford Smooth Pearl.

Alignment check prints and nozzle checks seem fine, oddly enough. And I’ve done head alignment on the printer several times, both manually and the auto mode alignment. And both from the printer's control panel and from the Mac's driver.

In a recent development, it has deposited some ink smears of black ink outside the printed area. (Probably a completely separate problem.)

The first image shows the alignment issue. It's a 1-1 macro shot of the print shown in the second image.View attachment 187723

Below, you can see the smearing issue. (White balance on these jpegs is not great, but that doesn't relate to the issue shown.)
View attachment 187725

Does anyone have any idea what’s going on? Has this printer reached end of life?
I wonder if it is the printer or the image which is sent to the printer. I guess you have checked the file at extreme enlargement (600% or more). Are details in the foreground (for example the oar or other small details also showing the same problem at extreme enlargement of the print. What size are your prints and did you let the printer driver upsize the image
or did you upsize the image before printing. I would begin by checking the file and software before giving up on the hardware.
The black smears don't look like the ones I get when the print head hits the paper because paper is too thick for the platen and paper thickness settings. This has never happened to me with Ilford Smooth Pearl which isn't a very thick paper. Try setting the paper thickness to 4 and the platen to Wide
I apologize if all this is redundant info and doesn't help at all
 

Attachments

Top